F.E.A.R. 3 SLI Bugged – PC gamers advised to run in Single GPU Mode

Since we got our PC review code of Warner Bros’ and Day 1 Studios’ latest FPS title, we’ve been messing with it to see how it performs. Although Nvidia has already included an SLI profile for F.E.A.R. 3 in their latest ForceWare drivers, that particular profile is bugged and actually causes negative performance.
With our system that is consisted of a Q9650 @ 4.2Ghz, 4GB DDR2 and a GTX295, the game’s performance was dropping to mid-30s with low GPU usage for no apparent reasons -at 1080p with max settings. At first we thought that it was a CPU limitation (as the game is optimized for dualcores) but our CPU usage was pretty low. Therefore we decided to run the game in Single GPU mode and voila. The game was running with constant 60fps and our GPU usage was always above 90%.
We’ve contacted Nvidia and hopefully there will be a fix in the latest ForceWare drivers. For the time being, those of you with SLI systems that notice major framerate drops should run the game in Single-GPU Mode.
Expect a Performance Analysis in the following days!

John Papadopoulos

John is the founder and Editor in Chief at DSOGaming. He is a PC gaming fan and highly supports the modding and indie communities. Before creating DSOGaming, John worked on numerous gaming websites. While he is a die-hard PC gamer, his gaming roots can be found on consoles. John loved - and still does - the 16-bit consoles, and considers SNES to be one of the best consoles. Still, the PC platform won him over consoles. That was mainly due to 3DFX and its iconic dedicated 3D accelerator graphics card, Voodoo 2. John has also written a higher degree thesis on the "The Evolution of PC graphics cards." Contact: Email